A network tool for managing many disparate systems
 
Files
[binary rpm] 1.2M
Apr 04 22:16:09 CEST 2013
puppet-2.7.21-2.el5.i386.rpm  - A network tool for managing many disparate systems
http://puppetlabs.com
Name: puppet
Version: 2.7.21
Release: 2.el5
Group: System Environment/Base
Size: 3275748
   
Build on: Thu Apr 4 22:16:07 2013
Vendor: ATrpms.net
Packager: ATrpms
Signature: DSA/SHA1, Thu Apr 4 22:16:09 2013 ( [expires: 2007-12-31])

Puppet lets you centrally manage every important aspect of your system using a
cross-platform specification language that manages all the separate elements
normally aggregated in different files, like users, cron jobs, and hosts,
along with obviously discrete elements like packages, services, and files.

   

Mon Mar 18 13:00:00 2013 Todd Zullinger - 2.7.21-2
- Apply upstream fix for fqdn_rand function with ruby-1.9 (#880959)
- Apply upstream fix to make WEBrick more tolerant of old clients (#831303)
- Apply upstream fix to avoid deprecated iconv (#809911)
- Apply upstream fix to avoid class level variables (#809911)

Wed Mar 13 13:00:00 2013 Michael Stahnke - 2.7.21-1
- Fixes for CVE-2013-1640 CVE-2013-1652 CVE-2013-1653 CVE-2013-1654
- CVE-2013-1655 CVE-2013-2274 CVE-2013-2275
- Remove Ruby 1.9.3 load file patch. It's now upstream
- Remove install permissions patch. It's now upstream

Wed Jul 11 14:00:00 2012 Todd Zullinger - 2.7.18-1
- Update to 2.7.17, fixes CVE-2012-3864, CVE-2012-3865, CVE-2012-3866,
CVE-2012-3867
- Improve NetworkManager compatibility, thanks to Orion Poplawski (#532085)
- Preserve timestamps when installing files

Wed Apr 25 14:00:00 2012 Todd Zullinger - 2.7.13-1
- Update to 2.7.13
- Change license from GPLv2 to ASL 2.0
- Drop %post hacks to deal with upgrades from 0.25
- Minor rpmlint fixes
- Backport patch to silence confine warnings in ruby-1.9.3

Wed Apr 11 14:00:00 2012 Todd Zullinger - 2.6.16-1
- Update to 2.6.16, fixes CVE-2012-1986, CVE-2012-1987, and CVE-2012-1988
- Correct permissions of /var/log/puppet (0750)

Wed Feb 22 13:00:00 2012 Todd Zullinger - 2.6.14-1
- Update to 2.6.14, fixes CVE-2012-1053 and CVE-2012-1054

Mon Feb 13 13:00:00 2012 Todd Zullinger - 2.6.13-3
- Move rpmlint fixes to %prep, add a few additional fixes
- Bump minimum ruby version to 1.8.5 now that EL-4 is all but dead
- Update install locations for Fedora-17 / Ruby-1.9
- Use ruby($lib) for augeas and shadow requirements
- Only try to run 0.25.x -> 2.6.x pid file updates on EL

Thu Jan 5 13:00:00 2012 Todd Zullinger - 2.6.13-2
- Revert to minimal patch for augeas >= 0.10 (bz#771097)

Wed Dec 14 13:00:00 2011 Todd Zullinger - 2.6.13-1
- Update to 2.6.13
- Cherry-pick various augeas fixes from upstream (bz#771097)

Sun Oct 23 14:00:00 2011 Todd Zullinger - 2.6.12-1
- Update to 2.6.12, fixes CVE-2011-3872
- Add upstream patch to restore Mongrel XMLRPC functionality (upstream #10244)
- Apply partial fix for upstream #9167 (tagmail report sends email when nothing
happens)

Thu Sep 29 14:00:00 2011 Todd Zullinger - 2.6.6-3
- Apply upstream patches for CVE-2011-3869, CVE-2011-3870, CVE-2011-3871, and
upstream #9793

Tue Sep 27 14:00:00 2011 Todd Zullinger - 2.6.6-2
- Apply upstream patch for CVE-2011-3848

Wed Mar 16 13:00:00 2011 Todd Zullinger - 2.6.6-1
- Update to 2.6.6
- Ensure %pre exits cleanly
- Fix License tag, puppet is now GPLv2 only
- Create and own /usr/share/puppet/modules (#615432)
- Properly restart puppet agent/master daemons on upgrades from 0.25.x
- Require libselinux-utils when selinux support is enabled
- Support tmpfiles.d for Fedora >= 15 (#656677)
- Apply a few upstream fixes for 0.25.5 regressions

Wed Feb 9 13:00:00 2011 Fedora Release Engineering - 0.25.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild

Mon May 17 14:00:00 2010 Todd Zullinger - 0.25.5-1
- Update to 0.25.5
- Adjust selinux conditional for EL-6
- Apply rundir-perms patch from tarball rather than including it separately
- Update URL's to reflect the new puppetlabs.com domain

Fri Jan 29 13:00:00 2010 Todd Zullinger - 0.25.4-1
- Update to 0.25.4

Tue Jan 19 13:00:00 2010 Todd Zullinger - 0.25.3-2
- Apply upstream patch to fix cron resources (upstream #2845)

Mon Jan 11 13:00:00 2010 Todd Zullinger - 0.25.3-1
- Update to 0.25.3

Tue Jan 5 13:00:00 2010 Todd Zullinger - 0.25.2-1.1
- Replace %define with %global for macros

Tue Jan 5 13:00:00 2010 Todd Zullinger - 0.25.2-1
- Update to 0.25.2
- Fixes CVE-2010-0156, tmpfile security issue (#502881)
- Install auth.conf, puppetqd manpage, and queuing examples/docs

Wed Nov 25 13:00:00 2009 Jeroen van Meeuwen - 0.25.1-1
- New upstream version

Tue Oct 27 13:00:00 2009 Todd Zullinger - 0.25.1-0.3
- Update to 0.25.1
- Include the pi program and man page (R.I.Pienaar)

Sat Oct 17 14:00:00 2009 Todd Zullinger - 0.25.1-0.2.rc2
- Update to 0.25.1rc2

Tue Sep 22 14:00:00 2009 Todd Zullinger - 0.25.1-0.1.rc1
- Update to 0.25.1rc1
- Move puppetca to puppet package, it has uses on client systems
- Drop redundant %doc from manpage %file listings

Fri Sep 4 14:00:00 2009 Todd Zullinger - 0.25.0-1
- Update to 0.25.0
- Fix permissions on /var/log/puppet (#495096)
- Install emacs mode and vim syntax files (#491437)
- Install ext/ directory in %{_datadir}/%{name} (/usr/share/puppet)

Mon May 4 14:00:00 2009 Todd Zullinger - 0.25.0-0.1.beta1
- Update to 0.25.0beta1
- Make Augeas and SELinux requirements build time options

Mon Mar 23 13:00:00 2009 Todd Zullinger - 0.24.8-1
- Update to 0.24.8
- Quiet output from %pre
- Use upstream install script
- Increase required facter version to >= 1.5

Tue Dec 16 13:00:00 2008 Todd Zullinger - 0.24.7-4
- Remove redundant useradd from %pre

Tue Dec 16 13:00:00 2008 Jeroen van Meeuwen - 0.24.7-3
- New upstream version
- Set a static uid and gid (#472073, #471918, #471919)
- Add a conditional requirement on libselinux-ruby for Fedora >= 9
- Add a dependency on ruby-augeas

Wed Oct 22 14:00:00 2008 Todd Zullinger - 0.24.6-1
- Update to 0.24.6
- Require ruby-shadow on Fedora and RHEL >= 5
- Simplify Fedora/RHEL version checks for ruby(abi) and BuildArch
- Require chkconfig and initstripts for preun, post, and postun scripts
- Conditionally restart puppet in %postun
- Ensure %preun, %post, and %postun scripts exit cleanly
- Create puppet user/group according to Fedora packaging guidelines
- Quiet a few rpmlint complaints
- Remove useless %pbuild macro
- Make specfile more like the Fedora/EPEL template

Mon Jul 28 14:00:00 2008 David Lutterkort - 0.24.5-1
- Add /usr/bin/puppetdoc

Thu Jul 24 14:00:00 2008 Brenton Leanhardt
- New version
- man pages now ship with tarball
- examples/code moved to root examples dir in upstream tarball

Tue Mar 25 13:00:00 2008 David Lutterkort - 0.24.4-1
- Add man pages (from separate tarball, upstream will fix to

   

include in main tarball)

Mon Mar 24 13:00:00 2008 David Lutterkort - 0.24.3-1
- New version

Wed Mar 5 13:00:00 2008 David Lutterkort - 0.24.2-1
- New version

Sat Dec 22 13:00:00 2007 David Lutterkort - 0.24.1-1
- New version

Mon Dec 17 13:00:00 2007 David Lutterkort - 0.24.0-2
- Use updated upstream tarball that contains yumhelper.py

Fri Dec 14 13:00:00 2007 David Lutterkort - 0.24.0-1
- Fixed license
- Munge examples/ to make rpmlint happier

Wed Aug 22 14:00:00 2007 David Lutterkort - 0.23.2-1
- New version

Thu Jul 26 14:00:00 2007 David Lutterkort - 0.23.1-1
- Remove old config files

Wed Jun 20 14:00:00 2007 David Lutterkort - 0.23.0-1
- Install one puppet.conf instead of old config files, keep old configs
around to ease update
- Use plain shell commands in install instead of macros

Wed May 2 14:00:00 2007 David Lutterkort - 0.22.4-1
- New version

Thu Mar 29 14:00:00 2007 David Lutterkort - 0.22.3-1
- Claim ownership of _sysconfdir/puppet (bz 233908)

Mon Mar 19 13:00:00 2007 David Lutterkort - 0.22.2-1
- Set puppet's homedir to /var/lib/puppet, not /var/puppet
- Remove no-lockdir patch, not needed anymore

Mon Feb 12 13:00:00 2007 David Lutterkort - 0.22.1-2
- Fix bogus config parameter in puppetd.conf

Sat Feb 3 13:00:00 2007 David Lutterkort - 0.22.1-1
- New version

Fri Jan 5 13:00:00 2007 David Lutterkort - 0.22.0-1
- New version

Mon Nov 20 13:00:00 2006 David Lutterkort - 0.20.1-2
- Make require ruby(abi) and buildarch: noarch conditional for fedora 5 or
later to allow building on older fedora releases

Mon Nov 13 13:00:00 2006 David Lutterkort - 0.20.1-1
- New version

Mon Oct 23 14:00:00 2006 David Lutterkort - 0.20.0-1
- New version

Tue Sep 26 14:00:00 2006 David Lutterkort - 0.19.3-1
- New version

Mon Sep 18 14:00:00 2006 David Lutterkort - 0.19.1-1
- New version

Thu Sep 7 14:00:00 2006 David Lutterkort - 0.19.0-1
- New version

Tue Aug 1 14:00:00 2006 David Lutterkort - 0.18.4-2
- Use /usr/bin/ruby directly instead of /usr/bin/env ruby in
executables. Otherwise, initscripts break since pidof can't find the
right process

Tue Aug 1 14:00:00 2006 David Lutterkort - 0.18.4-1
- New version

Fri Jul 14 14:00:00 2006 David Lutterkort - 0.18.3-1
- New version

Wed Jul 5 14:00:00 2006 David Lutterkort - 0.18.2-1
- New version

Wed Jun 28 14:00:00 2006 David Lutterkort - 0.18.1-1
- Removed lsb-config.patch and yumrepo.patch since they are upstream now

Mon Jun 19 14:00:00 2006 David Lutterkort - 0.18.0-1
- Patch config for LSB compliance (lsb-config.patch)
- Changed config moves /var/puppet to /var/lib/puppet, /etc/puppet/ssl
to /var/lib/puppet, /etc/puppet/clases.txt to /var/lib/puppet/classes.txt,
/etc/puppet/localconfig.yaml to /var/lib/puppet/localconfig.yaml

Fri May 19 14:00:00 2006 David Lutterkort - 0.17.2-1
- Added /usr/bin/puppetrun to server subpackage
- Backported patch for yumrepo type (yumrepo.patch)

Wed May 3 14:00:00 2006 David Lutterkort - 0.16.4-1
- Rebuilt

Fri Apr 21 14:00:00 2006 David Lutterkort - 0.16.0-1
- Fix default file permissions in server subpackage
- Run puppetmaster as user puppet
- rebuilt for 0.16.0

Mon Apr 17 14:00:00 2006 David Lutterkort - 0.15.3-2
- Don't create empty log files in post-install scriptlet

Fri Apr 7 14:00:00 2006 David Lutterkort - 0.15.3-1
- Rebuilt for new version

Wed Mar 22 13:00:00 2006 David Lutterkort - 0.15.1-1
- Patch0: Run puppetmaster as root; running as puppet is not ready
for primetime

Mon Mar 13 13:00:00 2006 David Lutterkort - 0.15.0-1
- Commented out noarch; requires fix for bz184199

Mon Mar 6 13:00:00 2006 David Lutterkort - 0.14.0-1
- Added BuildRequires for ruby

Wed Mar 1 13:00:00 2006 David Lutterkort - 0.13.5-1
- Removed use of fedora-usermgmt. It is not required for Fedora Extras and
makes it unnecessarily hard to use this rpm outside of Fedora. Just
allocate the puppet uid/gid dynamically

Sun Feb 19 13:00:00 2006 David Lutterkort - 0.13.0-4
- Use fedora-usermgmt to create puppet user/group. Use uid/gid 24. Fixed
problem with listing fileserver.conf and puppetmaster.conf twice

Wed Feb 8 13:00:00 2006 David Lutterkort - 0.13.0-3
- Fix puppetd.conf

Wed Feb 8 13:00:00 2006 David Lutterkort - 0.13.0-2
- Changes to run puppetmaster as user puppet

Mon Feb 6 13:00:00 2006 David Lutterkort - 0.13.0-1
- Don't mark initscripts as config files

Mon Feb 6 13:00:00 2006 David Lutterkort - 0.12.0-2
- Fix BuildRoot. Add dist to release

Tue Jan 17 13:00:00 2006 David Lutterkort - 0.11.0-1
- Rebuild

Thu Jan 12 13:00:00 2006 David Lutterkort - 0.10.2-1
- Updated for 0.10.2 Fixed minor kink in how Source is given

Wed Jan 11 13:00:00 2006 David Lutterkort - 0.10.1-3
- Added basic fileserver.conf

Wed Jan 11 13:00:00 2006 David Lutterkort - 0.10.1-1
- Updated. Moved installation of library files to sitelibdir. Pulled
initscripts into separate files. Folded tools rpm into server

Thu Nov 24 13:00:00 2005 Duane Griffin
- Added init scripts for the client

Wed Nov 23 13:00:00 2005 Duane Griffin
- First packaging



Use the mailing lists or the bug tracking system for comments, bugs and requests about the packages.
ATrpms was founded by Axel Thimm